How to fix problems with NextGen Gallery 2.*

[drop­cap style=“simple”]I[/dropcap] used to love NGG. Until the­re was ver­si­on 2.* When I first upgra­ded, the who­le site went down — mis­sing galle­ries, no pictu­res. The solu­ti­on was obvi­ous — unin­stall the plu­gin and install the older ver­si­on. No need to say, it dele­ted all the code from all the posts and pages. Luc­ki­ly, my hos­ting pro­vi­der backs up my site eve­ry day, so the next day I was hap­pi­ly run­ning ver­si­on 1.19.13 aga­in.

[drop­cap style=“simple”]T[/dropcap]he second attempt to upgra­de came after about a mon­th or so, when one of my cru­cial plu­gins — Jus­ti­fied Image Grid was upda­ted to work with NGG 2.*. It was, wait a sec…, a disas­ter aga­in! Yes! I tried to roll back to 1.19.13 and it wor­ked, except that the WYSIWYG edi­tor got bro­ken. It took me more than a week to fix it, but finally I was able to get my web back to work — see more here.

[drop­cap style=“simple”]W[/dropcap]ell, a man is a con­fir­med cre­a­tu­re. Yes, I did it aga­in. About a week ago. Rea­son? Well, Wor­d­Press kept urging me to upda­te to the latest ver­si­on. OK, it’s been long enou­gh for Pho­to­cra­ti to fix the pro­blems, have­n’t it? Yes, you­’re right, it has­n’t been… This time, most things see­med to work, pictu­res did show, galle­ries were cre­a­ted. BUT: no opti­on to uplo­ad a ZIP file, the “Import fol­der” fea­tu­re I loved using, sin­ce I first uplo­ad my pho­tos to Piwi­go and then sha­re the locati­on with NGG, the meta­da­ta view is use­less as it does­n’t allow you to scroll down, you can’t chan­ge the path for a sin­gle galle­ry, etc.

[drop­cap style=“simple”]T[/dropcap]hat’s exact­ly the time when you find your­self wishing to back to pre­vi­ous ver­si­on even knowing the­re will be no more bug­fi­xes or new fea­tu­res. BUT you can have the pre­vi­ous ver­si­on even with bug­fi­xes and may­be, one day, even with new fea­tu­res. The solu­ti­on bears the name Next­Cellent Galle­ry. Basi­cally is is a fork of NGG 1.19.13 which nowa­da­ys rea­ched ver­si­on 1.19.15. just install it, deacti­va­te NGG, acti­va­te NCG and you­’re done. Eve­ry­thing works, all troubles are gone. You even don’t have to unin­stall NGG, just deacti­va­te it, and if it ever beco­mes usa­ble aga­in one day, you can switch to it. Per­so­nally, I don’t think I will…

PS The only NGG plu­gin that refuses to work with NCG is Next­GEN Galle­ry Media Lib­ra­ry Addon, but no big deal…